Using downloaded FMP backup files with FMS

Homepage Forums FMPHost Control Panel Using downloaded FMP backup files with FMS

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #184
    Bruce Steedman

    I have successfully downloaded a backup file from the control panel and opened the .fmp12 file. This works fine if opened directly with FileMaker Pro, but I ran into trouble when I uploaded this same file to my local verison of FileMaker Server for testing. The file opened with read-only access and when I checked my FMS ‘Status’ page I saw the following warning:-
    “Opened database read only because it has multiple hard links and may be a FileMaker Server backup file. You must make a copy of the file and open the copy to make changes.”
    I made a copy, as suggested and re-uploaded it – all worked as normal.
    I have not encountered this issue with files downloaded from my own copy of FMS – which can be hosted elsewhere without issues. I note that downloading a copy file from the FMS console is different to the process via the FMPHost console (database needs to be closed first).
    Question: I was not aware of this issue, are FMP backup files somehow different to normal files and is there any other solution to this issue, aside from the workaround described (making a copy first)? Many thanks.
    Bruce Steedman (Environment: FMPA 13, FMS 13. Mac OSX 10.9.2)

    Carl Horton

    When we create a backup, we first check the status of the database. If it’s Open, then we tell FileMaker Server to make a backup of it and we turn that backup into a ZIP archive. It’s the ZIP archive you are downloading. What are you are describing is the first I’ve heard of this kind of issue, but perhaps it is caused by FileMaker Server creating a live snapshot versus just a file copy if the database was closed. Glad there is a workaround though if the problem arises.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.